t02007

de38712

1 @ SunOS 5.11 i86pc 1.04 32_gcc4.7 uplex

*    top   0.0 TEST ../../../bin/varnishtest/tests/t02007.vtc starting
[...]
*    top   0.0 TEST H2 Huge response headers
[...]
**** s1    0.5 rxhdr|content-length: 7\r
**** s1    0.5 rxhdr|X-Forwarded-For: 127.0.0.1\r
**** s1    0.5 rxhdr|X-Varnish: 1002\r
**** s1    0.5 rxhdr|Host: 127.0.0.1\r
**** s1    0.5 rxhdr|Transfer-Encoding: chunked\r
**** s1    0.5 rxhdr|\r
**** s1    0.5 rxhdrlen = 168
**** s1    0.5 http[ 0] |POST
**** s1    0.5 http[ 1] |/
**** s1    0.5 http[ 2] |HTTP/1.1
**** s1    0.5 http[ 3] |content-type: text/plain
**** s1    0.5 http[ 4] |scheme: http
**** s1    0.5 http[ 5] |content-length: 7
**** s1    0.5 http[ 6] |X-Forwarded-For: 127.0.0.1
**** s1    0.5 http[ 7] |X-Varnish: 1002
**** s1    0.5 http[ 8] |Host: 127.0.0.1
**** s1    0.5 http[ 9] |Transfer-Encoding: chunked
**** s1    0.5 len|007\r
**** s1    0.5 chunk|request
**** s1    0.5 len|0\r
**** s1    0.5 bodylen = 7
**   s1    0.5 === expect req.proto == HTTP/1.1
**** s1    0.5 EXPECT req.proto (HTTP/1.1) == "HTTP/1.1" match
**   s1    0.5 === txresp -hdr "Content-Type: text/plain" -hdrlen Foo 100 -body...
**** s1    0.5 txresp|HTTP/1.1 200 OK\r
**** s1    0.5 txresp|Content-Type: text/plain\r
**** s1    0.5 txresp|Foo: 9876543210987654321098765432109876543210987654321098765432109876543210987654321098765432109876543210\r
**** s1    0.5 txresp|Content-Length: 100\r
**** s1    0.5 txresp|\r
**** s1    0.5 txresp|!"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_
**** s1    0.5 txresp|"#$%&'()*+,-./0123456789:;<=>?@ABCD
***  s1    0.5 shutting fd 4
**   s1    0.5 Ending
***  c1    0.5 rx: stream: 1, type: HEADERS (1), flags: 0x00, size: 64
**   c1    0.5 === rxresp
***  c1    0.5 rx: stream: 1, type: CONTINUATION (9), flags: 0x00, size: 64
---- c1    0.5 Frame #1 for rxresp was of type CONTINUATION (9) instead of HEADERS (1)
*    diag  0.0 Assert error in receive_frame(), ../../../bin/varnishtest/vtc_http2.c line 839:
*    diag  0.0   Condition((vsb) == 0) not true.
#    top  TEST ../../../bin/varnishtest/tests/t02007.vtc FAILED (0.504) signal=6

1 @ Ubuntu LTS i686 1.04 fgs

*    top   0.0 TEST ../../../bin/varnishtest/tests/t02007.vtc starting
[...]
*    top   0.0 TEST H2 Huge response headers
[...]
**** s1    0.6 rxhdr|content-length: 7\r
**** s1    0.6 rxhdr|X-Forwarded-For: 127.0.0.1\r
**** s1    0.6 rxhdr|X-Varnish: 1002\r
**** s1    0.6 rxhdr|Host: 127.0.0.1\r
**** s1    0.6 rxhdr|Transfer-Encoding: chunked\r
**** s1    0.6 rxhdr|\r
**** s1    0.6 rxhdrlen = 168
**** s1    0.6 http[ 0] |POST
**** s1    0.6 http[ 1] |/
**** s1    0.6 http[ 2] |HTTP/1.1
**** s1    0.6 http[ 3] |content-type: text/plain
**** s1    0.6 http[ 4] |scheme: http
**** s1    0.6 http[ 5] |content-length: 7
**** s1    0.6 http[ 6] |X-Forwarded-For: 127.0.0.1
**** s1    0.6 http[ 7] |X-Varnish: 1002
**** s1    0.6 http[ 8] |Host: 127.0.0.1
**** s1    0.6 http[ 9] |Transfer-Encoding: chunked
**** s1    0.6 len|007\r
**** s1    0.6 chunk|request
**** s1    0.6 len|0\r
**** s1    0.6 bodylen = 7
**   s1    0.6 === expect req.proto == HTTP/1.1
**** s1    0.6 EXPECT req.proto (HTTP/1.1) == "HTTP/1.1" match
**   s1    0.6 === txresp -hdr "Content-Type: text/plain" -hdrlen Foo 100 -body...
**** s1    0.6 txresp|HTTP/1.1 200 OK\r
**** s1    0.6 txresp|Content-Type: text/plain\r
**** s1    0.6 txresp|Foo: 9876543210987654321098765432109876543210987654321098765432109876543210987654321098765432109876543210\r
**** s1    0.6 txresp|Content-Length: 100\r
**** s1    0.6 txresp|\r
**** s1    0.6 txresp|!"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_
**** s1    0.6 txresp|"#$%&'()*+,-./0123456789:;<=>?@ABCD
***  s1    0.6 shutting fd 5
**   s1    0.6 Ending
***  c1    0.6 rx: stream: 1, type: HEADERS (1), flags: 0x00, size: 64
**   c1    0.6 === rxresp
***  c1    0.6 rx: stream: 1, type: CONTINUATION (9), flags: 0x00, size: 64
---- c1    0.6 Frame #1 for rxresp was of type CONTINUATION (9) instead of HEADERS (1)
*    diag  0.0 Assert error in receive_frame(), ../../../bin/varnishtest/vtc_http2.c line 839:
*    diag  0.0   Condition((vsb) == 0) not true.
#    top  TEST ../../../bin/varnishtest/tests/t02007.vtc FAILED (0.865) signal=6

1 @ Ubuntu LTS i686 1.04 fgs

*    top   0.0 TEST ../../../bin/varnishtest/tests/t02007.vtc starting
[...]
*    top   0.0 TEST H2 Huge response headers
[...]
**** s1    0.6 rxhdr|content-length: 7\r
**** s1    0.6 rxhdr|X-Forwarded-For: 127.0.0.1\r
**** s1    0.6 rxhdr|X-Varnish: 1002\r
**** s1    0.6 rxhdr|Host: 127.0.0.1\r
**** s1    0.6 rxhdr|Transfer-Encoding: chunked\r
**** s1    0.6 rxhdr|\r
**** s1    0.6 rxhdrlen = 168
**** s1    0.6 http[ 0] |POST
**** s1    0.6 http[ 1] |/
**** s1    0.6 http[ 2] |HTTP/1.1
**** s1    0.6 http[ 3] |content-type: text/plain
**** s1    0.6 http[ 4] |scheme: http
**** s1    0.6 http[ 5] |content-length: 7
**** s1    0.6 http[ 6] |X-Forwarded-For: 127.0.0.1
**** s1    0.6 http[ 7] |X-Varnish: 1002
**** s1    0.6 http[ 8] |Host: 127.0.0.1
**** s1    0.6 http[ 9] |Transfer-Encoding: chunked
**** s1    0.6 len|007\r
**** s1    0.6 chunk|request
**** s1    0.6 len|0\r
**** s1    0.6 bodylen = 7
**   s1    0.6 === expect req.proto == HTTP/1.1
**** s1    0.6 EXPECT req.proto (HTTP/1.1) == "HTTP/1.1" match
**   s1    0.6 === txresp -hdr "Content-Type: text/plain" -hdrlen Foo 100 -body...
**** s1    0.6 txresp|HTTP/1.1 200 OK\r
**** s1    0.6 txresp|Content-Type: text/plain\r
**** s1    0.6 txresp|Foo: 9876543210987654321098765432109876543210987654321098765432109876543210987654321098765432109876543210\r
**** s1    0.6 txresp|Content-Length: 100\r
**** s1    0.6 txresp|\r
**** s1    0.6 txresp|!"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_
**** s1    0.6 txresp|"#$%&'()*+,-./0123456789:;<=>?@ABCD
***  s1    0.6 shutting fd 5
**   s1    0.6 Ending
***  c1    0.6 rx: stream: 1, type: HEADERS (1), flags: 0x00, size: 64
**   c1    0.6 === rxresp
***  c1    0.6 rx: stream: 1, type: CONTINUATION (9), flags: 0x00, size: 64
---- c1    0.6 Frame #1 for rxresp was of type CONTINUATION (9) instead of HEADERS (1)
*    diag  0.0 Assert error in receive_frame(), ../../../bin/varnishtest/vtc_http2.c line 839:
*    diag  0.0   Condition((vsb) == 0) not true.
#    top  TEST ../../../bin/varnishtest/tests/t02007.vtc FAILED (0.772) signal=6